Likes Likes:  0
Results 1 to 2 of 2

Thread: EVH 5150III EL34 50w Crunch channel just stopped working.....dead silence.

  1. #1
    Tone Member
    Join Date
    Mar 2017
    Posts
    322

    Default EVH 5150III EL34 50w Crunch channel just stopped working.....dead silence.

    Was playing this earlier today and after about 30 seconds of playing, channel 2 (crunch) just stopped working completely. Channels 1 and 3 work perfectly fine. tried a few cable swaps/on/off and still nothing.

    any reasons why this would happen? What is the issue?
    Charvel, Kramer, Gibson, Fender, MIJ/US Epiphone, Ibanez
    Full Shred, Distortion, JB, Custom (Custom), Screamin' Demon, Lil' Screamin' Demon, Nazgul, Cool Rails, Alternative 8, Mini Humbucker, Lil 59, 59, APH-1, Black Winter, Silverbird, SP90, PATB1, PATB3, YJM, 59/custom hybrid, SSL-1 AH1BJ, Jazz

  2. #2
    Super Toneologist Coma's Avatar
    Join Date
    Jul 2005
    Location
    Sweden
    Posts
    1,485

    Default Re: EVH 5150III EL34 50w Crunch channel just stopped working.....dead silence.

    Anything smell like burning? Are the tubes working properly?
    --------------------------------------------------------
    1973 Aria 551
    1984 Larrivee RS-4 w/ EMG SA/SA/89
    1989 Charvel 750 XL w/ DMZ Tone Zone & Air Norton
    1990's noname crap-o-caster plywood P/J Bass
    1991 Heartfield Elan III w/ DMZ mystery pups
    1995 Aria Pro II TA-65
    2001 Gibson Les Paul Gothic w/ PG-1 & SH-8

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •